
DAZ | Studio Content Manager Tutorial 

 
What is DAZ | Studio Content Manager and why should I use it? 
 DAZ introduced the DAZ | Studio Content Manager as a way to easily organize a huge range of content in 
a user-customizable fashion that suites your individual workflow.  There are several advantages to using the D|S 
Content Manager.  First as I’ve already mentioned it allows you a personal choice in how to organize your content.  
As a side effect of this, it doesn’t break future updates, expansions and other features that future content 
installations might be looking for. The second major reason to consider using the D|S Content Manager is that it 
allows a user to categorize an item into multiple places without creating physical copies.  You’ll see more on this 
later! 
 
Who should use this tutorial? 
 There are two major classes of users who should review this tutorial.  New users will find it a great way to 
answer some of the very common questions regarding missing content and “empty” runtimes.  Experienced users 
might find a few tips and tricks that will help them streamline their content management process. 
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How to use this document 

This document was designed around teach concepts as much as specific how-tos and as such it should be 
useful to all types of users.  The main benefit of this approach is that concepts can be universally applied instead of 
limited to only the situations present in the tutorial.   There are some fundamental assumptions and definitions that 
need to be clear before proceeding. 
 
Document Conventions 

Abbreviations and definitions 
 D|S    DAZ | Studio, the application 
 DAZ   DAZ 3D, the company 
 Content  Figures, Textures, Poses, Morphs, etc.  Items used in 3D Applications 
 Category  In this context, means Content Category, or the virtual method of organizing 
    content in DAZ | Studio 2.0 and higher. 
 Folder   In this context, means File Folder, or the physical installation location on a 
    hard drive or storage device.  Also known as a “Directory.” 
 Menu   Dropdown list of choices obtained off of the main interface or by popup 
    after a mouse click. 
 Window  A display element of the DAZ | Studio application, ie, “The main window” 
Navigating  

Left-click  A single brief press of the left-hand mouse button.  On Macintosh 
computers, this is the main mouse button. 

Right-click  A single brief press of the right-hand mouse button.  On Macintosh 
   computers, this is achieved by pressing the “Control” button and clicking 
   the main mouse button. 
->   Denotes travelling from one menu entry, category or file folder to another 

 
Nouveau Style 

This entire document will utilize the Nouveau Interface Style (which should be the DAZ | Studio default) 
as well as the “2nd Level” Interface layout (again the default).  To change the Interface Style (if it doesn’t match the 
screenshots or if you’d like to see what the others look like) go to the Menu: View -> Interface Style -> Select Style.  
This will bring up the “Select a Style” window.  Using the pull down menu on the top-right portion, select your 
desired Interface Style.  You will see a brief sample of each style prior to applying it using the Accept or Apply 
buttons.  Remember to return to the Nouveau Style before continuing. 

 
 



And the Style Select window: 

 
 
By default, we’re using the “2nd Level” Interface layout.  The process of viewing and changing this 

preference is much like changing the interface style.  Go to the menu: View -> Interface Layout -> Select Layout 
and a new window should appear.  Feel free to experiment with this option but return to the default “2nd Level” 
choice before continuing. 

 
 
And the Layout Style window: 



 
 
Understanding the Differences between Content Categories and File Folders 

One very important concept that must be understood before continuing the tutorial is the difference 
between a File Folder and a Content Category.  While not strictly true, the easiest way to keep these two items 
straight is to think of File Folders as “real” and Content Categories as “virtual.”  Smith Micro’s Poser application 
uses what we’ll call the Runtime Folder method.  It has designated a special folder called “Runtime” which contains 
multiple, special purpose folders.  Each of these folders must be named a specific way and can usually only contain 
specific types of items.  This makes organizing File Folders tricky and somewhat “dangerous” because it’s easy to 
cause an installed product to cease to function. 

Content Categories, on the other hand, are virtual “pointers” to File Folders.  They reside in the content 
database stored inside a sub-folder of the file folder where DAZ | Studio was installed called “resources.”  The 
content database itself is simply named “content”.  Content Categories can be named almost anything, organized in 
almost any fashion and you won’t run the risk of any type of content installation problems as you could if you were 
moving actual file folders.  Furthermore, it is possible for a single item to appear in multiple categories at the same 
time.  With File Folders, you have to make physical copies, potentially “wasting” disk space! 
 
Changing views between D|S Content Manager and Folder styles 

Once you learn how to do so, switching between Folder views and the Category views is very simple.  The 
hardest part about it is finding the option!  To my knowledge there is no menu entry method of doing this so warm 
up the mouse and look for the black right-facing arrow to the left of the content tab.  We’ll call this spot the 
“Content Options button” from now on. Once you’ve found the correct spot, right click on it and you’ll get a 
popup menu that allows you to select your content viewing style. 



 
 

On this popup menu there are five items we’re currently concerned with don’t worry about the other 
options for now.  The first two menu options are “View Folders as List” and “View Folders as Tree”.  These are 
the non-Content Manager views and are instead, representations of the File Folders where content resides on your 
hard disk.  The next three options: “View Categories – Quick Start”, “View Categories as List” and “View 
Categories as Tree” are all Content Manager style views and use the virtual pointers we call Categories for 
organization.  To switch back and forth, simply right-click on the desired view name.  Make sure to switch back to 
“View Categories – Quick Start” before continuing. 
 

 
 

Showing and Hiding Empty Content Categories 
 Another special feature of the Content Manager is the ability to hide categories that have no entries.  I’m not 
really certain why this was included, but it can cause you some serious headaches.  To toggle between Showing and 
Hiding empty categories, right click anywhere in the left-most Category area and select “Hide Empty Categories” or 
“Show Empty Categories” depending on their current state.  Make sure you are set to “Show Empty Categories” 
before continuing. 



 
and showing again… 

 
 
Resizing the D|S Content Manager Window 
 When organizing content in D|S it is often easier to expand the Content Manager window so you can see 
more “levels” of categories at the same time.  You can expand or shrink the Content Manager window by left-
clicking and holding on the right edge of the window and dragging your mouse left or right.  Release the mouse 
button when it is the size you prefer.  I recommend enough room to show three or four layers of categories. 



 
 
… and the results! 

 



Searching for new content! 
Up until this point, everything has been about preparing to organize your content.  It’s almost time to start 

organizing!  First off, if you don’t already have him, I recommend you go to 
http://free.daz3d.com/free_weekly/detail.php?free_id=248 and download the wonderful (and free) DAZ 
Morphing Python by DAZ with textures by Ravnheart.  The only requirement is that have registered on DAZ’s 
page.  (You’re using DAZ | Studio, you have to have already done so!).  Now to install the Morphing Python 
simply double left-click on the installer file after the download is complete.   
 Now this is really basic but bare with me!  Here’s a few screenshots to help with the install process… 
 

 
 
… and next. 

 

http://free.daz3d.com/free_weekly/detail.php?free_id=248


… and next. 

 
… and next. 

 
 
 
 
 
 
 
 
 
 



… and next. 

 
… and next. 

 
And we wait… 



 
And next… 

 
And Done! 
 
 Once the Morphing Python is installed, it’s time to find it!  If you look around in the Content Manager, 
you’ll note he’s nowhere to be found, but a quick dig through the Folder views and you can find him.  This is 
because the Content Manager is virtual and doesn’t read from the hard disk real-time like the Folder views do.  To 
update your Content Manager, you need to left-click on the Content Options button and then left-click the “Search 
for Content” option in the resulting menu.  If this is the first time you’ve done this it might take awhile, especially if 
you’re an experienced user and are just investigating the Content Manager for the first time.  Don’t worry though, 
future searches are much faster! 
 As a reminder, click on the Content Options button and “Search for Content” as shown below… 



 
 
If your install is factory default, you’ll also get this window… Just click Yes and keep and then wait a few moments. 
 

 
 
The “Unassigned” Content Category 

One common complaint about the Content Manager is that, by default, everything ends up in the 
“Unassigned” (or “Uncategorized” depending on Interface Style) category.  The reason it does this is because DAZ 
has wisely opted for flexibility in the management and design of the Content Manager.  They could enforce rules to 
place certain types of content in certain directories, but that might as well be the Poser-like File Folder method!  
They could also “guess” and place items where they think they belong and still allow you to move them.  
Unfortunately, not everyone thinks the same way so there’s quite a bit of disagreement on what would go where!  
So basically, you and I, we want everything to start its life in the “Unassigned” category so that we can tell it where 
we want it live and not be dependent upon someone else’s ideas of how to “properly” organize content. 
 
Drag and Drop 

Now, this may seem pretty basic, but the easiest way to move content around in the Content Manager is to 
left-click and hold, move the mouse over where you want it to go, and then release the left mouse button.  This is 
called “drag and drop”.   So let’s drag and drop the Morphing Python to his new home in the Animals -> Land 
category.  To do this we first need to find him in the Unassigned Category.  Follow the numbers, left clicking on 1,2 
and then 3.  When it comes to 4, wait just a moment so we can get some more instructions!  You may have to scroll 
down a bit to find the Morphing Python in the list of DAZ Animals depending on what content you have installed. 



 
 
Okay, now that we’ve found him, left-click and hold, then drag him over to the “Animals” category and pause a 
moment.  You’ll see the menu automatically adjust and the sub-categories of “Air”, “Fantasy-SciFi”, “Land” and 
“Sea” appear.  Keeping the left mouse button pressed, drag him over “Land” and release the button.   
If you’ve done everything right you can click on Animals (5), Land(6), and you should see him now (7) in his new 
home! 



 
 

Working with Content Categories 
So okay, that was pretty easy, but if I put all my land animals directly in the “Land” category, won’t it get 

pretty full?  Why yes, yes it will!  So we need to do something about that.  Let’s take a few minutes to practice some 
basics of the Content Manager.  We will create a new home from the Morphing Python, Rename a category, and 
yes, delete one too! 

To start off, Make sure you’re in the Animals -> Land category and can see the Morphing Python.  The first 
thing we’re going to do is Rename a category.  We’re going to take the existing category “Accessories” and change it 
to be “Morphing Python.”  Doing so is very simple, all you need to do is Right-Click on the word “Accessories” 
and select “Rename”. 



 
 
Type the name, then click the Accept button in the Category Name window 

 
It is important to understand that you MUST wait a few seconds after renaming a category before using it.  On 
most computers, this is really only 1-2 seconds, but if your computer is exceptionally busy or a little old and slow, it 
might take longer.  Just give it a brief pause before you navigate back to it. 
 
 Now we’ve got two categories left under “Land” that aren’t relevant at the moment.  You can either rename 
them, or for learning sake, we can delete them!  So Right-Click on the “Morphs” category and select Delete! 

 
 
Then confirm the deletion by clicking the OK button: 

 
You can now either rename the Motions/Poses folder or you can delete it.  It’s up to you!  
 
 Next we need to make a new category, this will function just like Renaming or deleting, except you want to 
right-click in the gray area next to the category you want the item to appear in.  So make sure you’re in Animals(1) -
> Land(2) -> Morphing Python(3) and then go ahead and try the right-click, and Create category here(4)! 



 
 
In the category name window type “MATs” and click Accept.  This is where we will place textures poses for the 
Morphing Python. 

 
We will come back to this in a moment… 
 
Special Content Category features and actions 

Now, one of the things to benefits about the Content Manager is that tells you when you haven’t used or 
“seen” an item in your content directory.  Most often you’ll find this in the Unassigned category, but it’s also 
possible to have it in more “official” ones.  If you’re in the View Categories As Quick Start view, you’ll notice that 
in front of some category names there is an “!” mark and in front of others there is a “*” and still others the text is 
bold.  Each of these states is significant and has a specific meaning.  In the Quick Start view, the “!” (1) means that 
this root level category contains an unviewed item.  The “*” (2) means that a subcategory view contains an 
unviewed item and bold text (3) means everything in this (sub)category is unviewed.  It is possible (likely!) that two 
states are shown at once.  You can see that on item 3. 

 
 
Even the items themselves inside a category provide information like this… You can see that I’ve clicked on 
(viewed) a few items (1) and not others (2).  Note the difference in the text and background.  You can even see the 
background difference in the screenshot above! 



 
Try it for yourself by navigating to Unassigned -> Poses -> Python!  Now when you’re bored with that we can get 
rid of all these silly marks, but using the Right-Click -> Mark as Viewed option 
 
Try it on the Figures category in Unassigned or if you’d like, on Unassigned itself! 

 
That’s a quick and easy way to mark everything in a folder (even outside the Unassigned category) as viewed.   
 
Mass moving content 

Okay, now that we’ve viewed a few things and seen how that works,  it’s time to move all this python stuff 
over to the MATs folder we created earlier.  Make sure you are in the Item window by clicking on one of the 
pictures of the python.  Then press the “CTRL” key and the “A” key at the same time.  This is a keyboard shortcut 
for “Select all”.  Now you’ve got all of them selected (and you’ll note they’re now all marked as viewed) you can 
left-click and hold on one, then drag it to Animals (pause) -> Land (pause) -> Morphing Python (pause) -> MATs.  
Release the left mouse button with your cursor ever the word MATs. 



 
Navigate to Animals -> Land -> Morphing Python -> MATs and review your handiwork!   



 
 
But wait!  Not only have we not moved the Python itself, we’ve put actual poses in the MATs folder.  Oh no!  First, 
using what you’ve learned move the Morphing Python out of Animals -> Land and into Animals -> Land -> 
Morphing Python.  Next, let’s create another new category called Motions/Poses under the Morphing Python 
category.  Now, we can’t really use CTRL+A to select everything we need to move in the MATs folder, but you can 
use the CTRL button while clicking on each icon that is an actual pose to select them in a group.  Do that and drag 
them to the newly created Motions/Poses category.  In the end you should end up with this: 



 
 
A couple more words on Categorization before we move on to the next method… Frequently, you’ll run into 
content that contains multiple MAT files for different versions of programs.  Most often you’ll see these denoted 
“P4”, “PP” and “P5”, but occasionally some newer styles will sneak in.  Each version has its own place and reason 
for being though P4 and PP are the most useful to DAZ | Studio.  P5 and up are not helpful to DAZ and may 
contain instructions that cause poor rendering results.  This doesn’t mean that they’re not usable, but it’s an 
advanced topic that won’t be covered here.   It is my recommendation that in these scenarios you make separate 
MAT folders for each version.  For example, using our Morphing Python, you could add 2 new categories under 
MATs called “P4 Unused” and “P5 Unused” and then move the appropriate MAT files to those directories.  This 
lets you have quick access to the “most correct” version of MAT files and still lets you keep the others in case 
someday DAZ | Studio learns to handle them better.  Another option, and I use this one as well is to create a 
“zzTrash” category on the root of your category list.  You add the “zz” to “Trash” so that it appears at the bottom 
of the list and remains out of your way.  Remember though, you want to create subcategories under trash, not only 
in case you want to “recover” something, but also because the Content Manager does not like to have more than 
about 1,000 items in any single content category so using sub-folders will protect you.   
 
Power Categorization 

Okay, time to download another freebie!  This time we’re going to grab Spirit Foxy’s Drakkorin Battle 
Weapons pack http://free.daz3d.com/free_weekly/detail.php?free_id=237 .  After you install it, search for content 
then look under Unassigned -> Props -> SF_Drakkorin  Good, you found it!  We’re going to cover one last basic 
content organization format before we get into real power categorization.  So far, everything we’ve done has been 
focused on items inside the Content Manager.  Did you know you can drag and drop folders too?  Let’s try it with 
the SF_Drakkorin folder.  Left-click and hold, drag to Scenes and Props (pause) -> Weapons (pause) and release.  

http://free.daz3d.com/free_weekly/detail.php?free_id=237


Neat huh!   Now let’s go find this in its new home and have some fun with power categorization!  Select Scenes and 
Props -> Weapons -> SF_Drakkorin.   
 
 What we’re going to explore here is what to do when you’d like an item to appear in multiple categories.  
Things like hair and texture sets that work across figures (Morphing Fantasy Dress comes to mind!) are good 
examples of stuff like this.  I picked the weapons, because they’re cool and it’s a small download.  Now before we 
go much further, there are a few dos and don’ts about using this method.  When using “Power Categorization” 
from the Unassigned area, it is only good for placing items in multiple categories at the same time.  If you only 
select one destination, a “copy” of this pointer will be left behind in the Unassigned category and you’ll be 
scratching your head wondering why!  The reason is that, since you cannot manually assign to the Unassigned 
category, the Categorize Content window doesn’t show you the Unassigned category and you cannot deselect the 
items Unassigned category.  Phew!  That will make more sense later, for now, just trust me.  If it’s Unassigned and 
destined for one place only, use drag and drop.  If you’re going to multiple destinations, use Power Categorization! 
 
So to get started, just Right-Click on the Scythe and select “Categorize”.   This is what I call Power Categorization! 

 
This brings up the Categorize Content Window.  You can do most everything related to categories in this window 
except selecting something new to categorize.  It only works on what you right clicked on earlier.  So let’s navigate 
around a bit.  Go to People -> Michael and create a new category called Weapons.   



 
 
Then click on the little square to the left of “Weapons” to select this location as a destination. 

 
 
Repeat this process for People -> Victoria.  Make sure you have the item properly placed before clicking the Accept 
button as this closes the Categorize Content window and you can misplace items fairly easily if you’re not careful.  
Double check for your checkmarks by browsing in the Categorize Content window to People -> Michael -> 
Weapons and People -> Victoria -> Weapons and make sure you see the checkmarks! 



 
 
Now suppose you don’t really want a weapons category under Michael and Victoria.  Well, we can reverse the 
process using Power Categorization.  Navigate to either People -> Michael -> Weapons or People -> Victoria -> 
Weapons and Right-Click, Categorize on the scythe again.  To remove the item from a category simply, uncheck the 
box next to the category name.  Be careful though, you don’t want to orphan the poor item.  If you do, the item will 
just end up in the root of the Unassigned category so all isn’t lost.  Let’s fix our little mess though.  Unselect the 
checkmark next to each of the Weapons categories we created and then go back to Scenes and Props -> Weapons -
> SF_Drakkorin and ADD a checkmark there.  Sadly, you cannot delete a category from within the Categorize 
Content window, so you’ll need to navigate to the two “Weapons” categories in the main Content Manager window 
to delete them.  Note, however, that you can Rename categories in this view, but just like creating or renaming them 
in the main window, it’s best to wait 1-2 seconds before using them after doing so. 
 

Using the Content Search Function 
Now one of the most awesome thing about the Content Manager is that since it is a database it is fully “indexed.”  
This means it performs searches much, much faster than your standard search feature on your disk drive.   So let’s 
take it for a test drive.  First, make sure you’re in the Content Manager view, and find the empty looking bar to the 
left of the magnifying glass. Let’s search for “standard” since we just installed something that uses that name. 



 
 
If all went well, you should see this down below: 

 
 
From here you can perform normal Drag and Drop operations as well as Right-Click -> Categorize functions.  It’s 
amazingly fast, but sadly it does have a few downsides.  1) It currently (as of 2.3.3.25) still doesn’t tell you where an 
item is categorized and 2) it cannot find folder names only item names.   

Backing up the database 
Okay, so you are worried about all this work you've done and want to protect it. Maybe the database will get 
corrupt? Maybe you'll make a huge mess of it, who knows? Either way, you'll probably want to make a backup of 
the database fairly frequently to ensure you don't lose all that effort. 
 
The beautiful thing about the Content Manager database is that it is a single file. Easily located and as long as D|S is 
not running, easy to backup! First, using your operating system's native file explorer, navigate to the directory where 
D|S is installed. On an MS Windows machine this defaults to c:\program files\daz\studio. Once you've navigated 
to that folder, you should see another subfolder named "Resources", go ahead and browse into that folder. In the 
list of files, there's one called "Content". It has no file extension and probably no associated applications. THAT, 



my friends, is your Content Database. To back it up, simply copy the file to another location. Preferably one that 
has all your other backups in it. That's all you have to do. Once the file is copied elsewhere, you've got your backup. 
 
To restore a prior version of the Content Database, go to your backup directory and simply copy the "Content" file 
to the ~\DAZ\Studio\Resources folder, overwriting the existing file. I recommend making a new, seperate backup 
first though! 
 

Starting over 
So, you've given up. Maybe you don't like the way you built your layout. Maybe it's corrupt and you have no backup. 
Either way, it's time to start over on the Content database. There are two methods of achieving this. Before you do 
either, please backup your database in case you change your mind! 
 
If D|S is currently running, you can simply go Edit -> Preferences -> Content Database and click the button 
labeled "Reset the Content Database" and then confirm your choice. Blamo. It's reset and everything will be 
Unassigned upon your next search. 
 
If you've just backed up your database and haven't launched D|S yet, you can simply delete the "Content" file and 
D|S will automagically recreate it when you start the application the next time. 
 
I hope you enjoyed this comprehensive tutorial on the DAZ | Studio Content Manager! 
 
Thanks! 
 -- Adam 
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